Android Central

Offer applies to phones bought from both Sony and T-Mobile

During the official announcement of the Sony Xperia Z1s at CES, we were told about the pretty fantastic content offering that Sony was throwing in with the handset. What they didn't mention at the time was a special offer involving PlayStation Plus. But if you've bought one, or are planning to buy one soon, you'll get a free 1-year subscription to PlayStation Plus thrown in for good measure. 

Sure, if you're an Xbox owner, this is probably the least interesting thing you'll hear all day. But, if you purchase an Xperia Z1s either from Sony or T-Mobile between January 13 and February 12 then you're eligible to claim the reward. All you need to do is head to the link below to redeem, and send Sony a photo of the IMEI number on the box as well as your purchase receipt for the phone. Do this by March 5 and you'll have it delivered to you by March 21. 

If you've not yet tried PlayStation Plus, then it's well worth cashing in here. Sony regularly offers members content free of charge, including this month the epic Bioshock Infinite for PS3. Just be sure not to lose your receipt! 

Source: Sony via Xperia Blog

 
There are 12 comments

D13H4RD2L1V3 says:

Damn.

I want a PS+ membership. Think of all the free games!

Jamaar White says:

During Black Friday, a year was on sale for 30 instead of 50, I got 2 years for one price

Posted via Android Central App

JBOOGBK says:

If I get it from sony will it be unlocked?

Jamaar White says:

Yes

Posted via Android Central App

abdo pac says:

Fuck them...

duoFurious says:

Had plus for the past year and a half and it's fantastic. Worth.

Posted via Android Central App

blazer236ix says:

That brings this phone down to 472 basically then.

DaFonZisBack says:

Tried the phone out today. Its barely different from the xperia z. And the bezel is gross.

Posted via Android Central App

so whats the link? i might be dumb but i cant find the link to sign up.

Hargoth says:

Link works, but when I try to submit, it fails, over and over and over ...

"The connection to the server was reset while the page was loading."

Tried both chrome and firefox :(

TMMBG says:

Same here Hargoth. Tried two different computers as well as my phone. No dice. Hopefully they will get this worked out.

TMMBG says:

I figured it out - there's a file size limit on the upload. I trimmed down both images and it worked fine.