If you're an Android application developer, this one is for you -- there's a bit of a show-stopping bug in the ADT plugin for Eclipse when used with the Android 2.3 SDK.Gingerdroid  Reports are in that after you upgrade your plugin, opening a non-Android library project results in the error "unable to execute dex: null."

The good news is that a fix has just been pushed, and you can now get ADT 8.0.1 and get back to work.

We doubt this is the only bug, just the first one found.  In any case, it's nice to see Google and Android developers take an interest.  To find a bit more info, check the Android Developers Google group.  [Android Developers] Thanks Joe!

 
There are 9 comments

Wait soo.... how do we update to 2.3 ginger over the air? Or do we have to go to our carriers to have them update it...?

This is for developers. It's part of the tools used to create Android apps.

As for your Gingerbread update, you'll have to wait for your carrier to get it out unless you're using a Nexus One. We'll be sure to post when and if these updates become available. :)

Wow... jerry answered my ?... thanks jerry...

You're welcome man. We all had these kind of questions at one time :)

^ wow

jmc2543 says:

Gotta love android noobes. They keep entertainment in our lives.

Hey hey hey! Ur right... i just came from iphone att and sooooo glad im here! Evo!

shammer64 says:

Sweet! I was wrestlingwith this bug yesterday.

potatoho says:

Grrrr..

/lib/i686/cmov/libc.so.6: version `GLIBC_2.8' not found

Emulator won't work on stable Debian lenny.